<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<meta http-equiv="content-type" content="text/html" charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="profile" href="//gmpg.org/xfn/11">
<title>Everrati breathes new life into classic Range Rover and Land Rover vehicles with luxury EV conversions &#8211; Lucire Men</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Lucire Men &raquo; Feed" href="http://luciremen.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Lucire Men &raquo; Comments Feed" href="http://luciremen.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Lucire Men &raquo; Everrati breathes new life into classic Range Rover and Land Rover vehicles with luxury EV conversions Comments Feed" href="http://luciremen.com/20221218/everrati-breathes-new-life-into-classic-range-rover-and-land-rover-vehicles-with-luxury-ev-conversions/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/luciremen.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='http://luciremen.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='radcliffe_style-css' href='http://luciremen.com/wp-content/themes/radcliffe/style.css?ver=6.0.1' type='text/css' media='all' />
<script type='text/javascript' src='http://luciremen.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='http://luciremen.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="http://luciremen.com/wp-json/" /><link rel="alternate" type="application/json" href="http://luciremen.com/wp-json/wp/v2/posts/2006" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://luciremen.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://luciremen.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.1" />
<link rel="canonical" href="http://luciremen.com/20221218/everrati-breathes-new-life-into-classic-range-rover-and-land-rover-vehicles-with-luxury-ev-conversions/" />
<link rel='shortlink' href='http://luciremen.com/?p=2006' />
<link rel="alternate" type="application/json+oembed" href="http://luciremen.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fluciremen.com%2F20221218%2Feverrati-breathes-new-life-into-classic-range-rover-and-land-rover-vehicles-with-luxury-ev-conversions%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://luciremen.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fluciremen.com%2F20221218%2Feverrati-breathes-new-life-into-classic-range-rover-and-land-rover-vehicles-with-luxury-ev-conversions%2F&#038;format=xml" />
<script type="text/javascript">
	window._zem_rp_post_id = '2006';
	window._zem_rp_thumbnails = true;
	window._zem_rp_post_title = 'Everrati+breathes+new+life+into+classic+Range+Rover+and+Land+Rover+vehicles+with+luxury+EV+conversions';
	window._zem_rp_post_tags = ['luxury', 'retro', 'electric+car', 'living', 'oxfordshire', 'uk', '1970s', 'environment', 'luxury+line', 'retromodernism', '022', 'electricity', 'lucire', 'range+rover', 'zero+emissions', 'car', 'land+rover', 'modernism', 'sustainability', '1970', 'england', 'gear', 'classic', 'car', 'andrew', 'niccol', 'film', 'fool', 'neoclass', 'gold', 'automot', 'bahama', 'life', 'design', 'rover', 'electr', 'ev'];
	window._zem_rp_static_base_url = 'https://content.zemanta.com/static/';
	window._zem_rp_wp_ajax_url = 'http://luciremen.com/wp-admin/admin-ajax.php';
	window._zem_rp_plugin_version = '1.12';
	window._zem_rp_num_rel_posts = '8';
</script>
<link rel="stylesheet" href="http://luciremen.com/wp-content/plugins/related-posts-by-zemanta/static/themes/vertical.css?version=1.12" />
<link rel="icon" href="http://luciremen.com/wp-content/uploads/cropped-luciremen180x150-32x32.gif" sizes="32x32" />
<link rel="icon" href="http://luciremen.com/wp-content/uploads/cropped-luciremen180x150-192x192.gif" sizes="192x192" />
<link rel="apple-touch-icon" href="http://luciremen.com/wp-content/uploads/cropped-luciremen180x150-180x180.gif" />
<meta name="msapplication-TileImage" content="http://luciremen.com/wp-content/uploads/cropped-luciremen180x150-270x270.gif" />
</head>
<body class="post-template-default single single-post postid-2006 single-format-standard wp-custom-logo">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg>
<a class="skip-link button" href="#site-content">Skip to the content</a>
<div class="header-search-block section light-padding hidden">
<div class="section-inner">
<form role="search" method="get" class="search-form" action="http://luciremen.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
</div>
<header class="header section light-padding" id="site-header">
<div class="header-inner section-inner">
<div class="blog-logo">
<a href="http://luciremen.com/" rel="home">
<span class="screen-reader-text">Lucire Men</span>
<img src="http://luciremen.com/wp-content/uploads/luciremen180x150.gif">
</a>
</div>
<button class="nav-toggle">
<p>Menu</p>
<div class="bars">
<div class="bar"></div>
<div class="bar"></div>
<div class="bar"></div>
</div>
</button>
<ul class="main-menu">
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18"><a href="http://luciremen.com/category/style/">Style</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="http://luciremen.com/category/culture/">Culture</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="http://luciremen.com/category/people/">Our People</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16"><a href="http://luciremen.com/category/gear/">Gear</a></li>
<li id="menu-item-50" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50"><a href="http://luciremen.com/?random">Random Page</a></li>
<li id="menu-item-189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189"><a href="http://luciremen.com/about-lucire-men/">About Us</a></li>
<li id="menu-item-38" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38"><a href="http://lucire.com/feedback.shtml">Contact Us</a></li>
<li class="search-toggle-menu-item">
<a href="#" class="search-toggle">
<span class="screen-reader-text">Show the search field</span>
</a>
</li>
</ul>
</div>
</header>
<div align=center>
<div style="display:block;max-width:730px; max-height:190px; margin-right:20px;" } <!-- * Advertising * -->

<ins data-revive-zoneid="33" data-revive-id="0e871bac9eee6ce976e99823ca8b99f2"></ins>
<script async src="https://adserver.jyanet.com/www/delivery/asyncjs.php"></script>

<P>&nbsp;
</div>
</div>
<div class="mobile-menu-container hidden">
<ul class="mobile-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18"><a href="http://luciremen.com/category/style/">Style</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="http://luciremen.com/category/culture/">Culture</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="http://luciremen.com/category/people/">Our People</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16"><a href="http://luciremen.com/category/gear/">Gear</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50"><a href="http://luciremen.com/?random">Random Page</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189"><a href="http://luciremen.com/about-lucire-men/">About Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38"><a href="http://lucire.com/feedback.shtml">Contact Us</a></li>
</ul>
<form role="search" method="get" class="search-form" action="http://luciremen.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form>
</div>
<main class="content" id="site-content">
<article id="post-2006" class="section post post-2006 type-post status-publish format-standard has-post-thumbnail hentry category-gear tag-1783 tag-506 tag-1970s tag-car tag-electric-car tag-electricity tag-england tag-environment tag-land-rover tag-living tag-lucire tag-luxury tag-luxury-line tag-modernism tag-oxfordshire tag-range-rover tag-retro tag-retromodernism tag-sustainability tag-uk tag-zero-emissions">
<figure class="featured-media" style="background-image: url( http://luciremen.com/wp-content/uploads/02-12-22-Everrati-Sprite-Photography-1-1440x960.jpg );">
<img width="1440" height="960" src="http://luciremen.com/wp-content/uploads/02-12-22-Everrati-Sprite-Photography-1-1440x960.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://luciremen.com/wp-content/uploads/02-12-22-Everrati-Sprite-Photography-1-1440x960.jpg 1440w, https://luciremen.com/wp-content/uploads/02-12-22-Everrati-Sprite-Photography-1-300x200.jpg 300w, https://luciremen.com/wp-content/uploads/02-12-22-Everrati-Sprite-Photography-1-1024x683.jpg 1024w, https://luciremen.com/wp-content/uploads/02-12-22-Everrati-Sprite-Photography-1-768x512.jpg 768w, https://luciremen.com/wp-content/uploads/02-12-22-Everrati-Sprite-Photography-1-1536x1024.jpg 1536w, https://luciremen.com/wp-content/uploads/02-12-22-Everrati-Sprite-Photography-1.jpg 1600w" sizes="(max-width: 1440px) 100vw, 1440px" />
</figure>
<div class="post-header section">
<div class="post-header-inner section-inner medium">
<div class="post-meta-top">
<a href="http://luciremen.com/20221218/everrati-breathes-new-life-into-classic-range-rover-and-land-rover-vehicles-with-luxury-ev-conversions/">December 18, 2022</a>
<span class="sep">/</span>
<a href="http://luciremen.com/20221218/everrati-breathes-new-life-into-classic-range-rover-and-land-rover-vehicles-with-luxury-ev-conversions/#respond" class="post-comments">0 comments</a>
</div>
<h1 class="post-title">Everrati breathes new life into classic Range Rover and Land Rover vehicles with luxury EV conversions</h1>
</div>
</div>
<div class="post-content entry-content section-inner thin">
<p><span class=introduction>Just like the neoclassical movement of the 1970s, the early 2020s are seeing new life breathed into earlier designs—except this time it&#8217;s the original Land Rover (Defender) and Range Rover that are in vogue</span><br />
&nbsp;<br />
<img src="https://lucire.com/2022/1217i1.jpg" /><br />
<img src="https://lucire.com/2022/1217i2.jpg" vspace=3 /><br />
<img src="https://lucire.com/2022/1217i3.jpg" /><br />
<img src="https://lucire.com/2022/1217i4.jpg" vspace=3 /><br />
<img src="https://lucire.com/2022/1217i5.jpg" /><br />
<span class=copyright>Sprite Photography</span><br />
&nbsp;<br />
You might be fooled into thinking we were taking our predictions about <a href="https://lucire.com/2022/1004fe0.shtml">the 1970s coming back</a> too seriously with the sight of this Bahama Gold Range Rover, in the original colour that the car was available in back in 1970—but this one’s electric.</p>
<p class=para>Along with the classic Land Rover 88 and Land Rover Defender pictured here, it’s the work of Everrati Automotive Ltd., which transforms these classics into zero-emission EVs from a bespoke facility in Upper Heyford, Oxfordshire. It seems the predictions in so many Andrew Niccol films like <em>Gattaca</em>—classic cars running modern powertrains—are coming true.</p>
<p class=para>The company had already delivered electric Land Rovers. It now extends its portfolio to these models incorporating an OEM-grade electric powertrain designed and developed in-house. It uses specialist build partners to maintain the highest quality, no doubt improving on what left the factory in Solihull many years before.</p>
<p class=para>The company adopts sustainable luxury materials, including the world’s lowest carbon leather from Bridge of Weir.</p>
<p class=para>‘Perfectly at home in London, Cornwall, Monterey or the Hamptons, these vehicles are right in the current <em>Zeitgeist</em>; rolling pieces of art that will give their owners, who are mavens of sustainability and responsibility, a clean and distinctive and luxurious way of travelling. At the same time these progressive machines will have a legacy, being preserved for generations who will be able to continue to use and enjoy them guilt-free, with zero emissions, as the automotive landscape changes around them,&#8217; said Everrati CEO and co-founder Justin Lunny.</p>
<p class=para>A Land Rover (Defender) conversion costs £185,000 plus VAT and donor vehicle, while the Range Rover is priced at £230,000 plus VAT and donor vehicle.</p>
<div class="zem_rp_wrap zem_rp_th_vertical" id="zem_rp_first"><div class="zem_rp_content"><h3 class="related_post_title"><br /><strong>Related posts</strong></h3><ul class="related_post zem_rp"><li data-position="0" data-poid="in-1930" data-post-type="none"><a href="http://luciremen.com/20220726/pierfrancesco-favino-and-david-beckham-re-create-the-persuaders/" class="zem_rp_thumbnail"><img src="http://luciremen.com/wp-content/uploads/Riva-The-Persuaders-Poster_Horizontal-Credits-Armando-Testa-Studios-Luca-Grafner-150x150.jpg" alt="Pierfrancesco Favino and David Beckham re-create &lt;em&gt;The Persuaders&lt;/em&gt;" width="150" height="150" /></a><a href="http://luciremen.com/20220726/pierfrancesco-favino-and-david-beckham-re-create-the-persuaders/" class="zem_rp_title">Pierfrancesco Favino and David Beckham re-create <em>The Persuaders</em></a></li><li data-position="1" data-poid="in-744" data-post-type="none"><a href="http://luciremen.com/20140902/land-rover-discovery-sport-revealed-claimed-to-be-most-versatile-capable-premium-compact-suv/" class="zem_rp_thumbnail"><img src="http://luciremen.com/wp-content/uploads/890892_LR_DS_Iceland_Location_10-150x150.jpg" alt="Land Rover Discovery Sport revealed—claimed to be most versatile, capable premium compact SUV" width="150" height="150" /></a><a href="http://luciremen.com/20140902/land-rover-discovery-sport-revealed-claimed-to-be-most-versatile-capable-premium-compact-suv/" class="zem_rp_title">Land Rover Discovery Sport revealed—claimed to be most versatile, capable premium compact SUV</a></li><li data-position="2" data-poid="in-534" data-post-type="none"><a href="http://luciremen.com/20130105/on-days-like-these-were-more-tempted-by-the-new-range-rover/" class="zem_rp_thumbnail"><img src="http://luciremen.com/wp-content/uploads/0815ll2-150x150.jpg" alt="On days like these, we&#8217;re more tempted by the new Range Rover" width="150" height="150" /></a><a href="http://luciremen.com/20130105/on-days-like-these-were-more-tempted-by-the-new-range-rover/" class="zem_rp_title">On days like these, we&#8217;re more tempted by the new Range Rover</a></li><li data-position="3" data-poid="in-1935" data-post-type="none"><a href="http://luciremen.com/20220820/aston-martin-announces-limited-edition-v12-vantage-roadster-700-ps-on-tap/" class="zem_rp_thumbnail"><img src="http://luciremen.com/wp-content/uploads/V12VantageRoadster_01-150x150.jpg" alt="Aston Martin announces limited-edition V12 Vantage Roadster, 700 PS on tap" width="150" height="150" /></a><a href="http://luciremen.com/20220820/aston-martin-announces-limited-edition-v12-vantage-roadster-700-ps-on-tap/" class="zem_rp_title">Aston Martin announces limited-edition V12 Vantage Roadster, 700 PS on tap</a></li><li data-position="4" data-poid="in-1872" data-post-type="none"><a href="http://luciremen.com/20220410/electrified-jaguar-xk140-by-lunaz-a-lavish-wedding-gift-for-brooklyn-beckham/" class="zem_rp_thumbnail"><img src="http://luciremen.com/wp-content/uploads/DSC08437-150x150.jpg" alt="Electrified Jaguar XK140 by Lunaz a lavish wedding gift for Brooklyn Beckham" width="150" height="150" /></a><a href="http://luciremen.com/20220410/electrified-jaguar-xk140-by-lunaz-a-lavish-wedding-gift-for-brooklyn-beckham/" class="zem_rp_title">Electrified Jaguar XK140 by Lunaz a lavish wedding gift for Brooklyn Beckham</a></li><li data-position="5" data-poid="in-1073" data-post-type="none"><a href="http://luciremen.com/20151110/aston-martin-premieres-film-on-db10-its-spectre-james-bond-car/" class="zem_rp_thumbnail"><img src="http://luciremen.com/wp-content/uploads/1109i3-150x150.jpg" alt="Aston Martin premières film on DB10, its &lt;i&gt;Spectre&lt;/i&gt; James Bond car" width="150" height="150" /></a><a href="http://luciremen.com/20151110/aston-martin-premieres-film-on-db10-its-spectre-james-bond-car/" class="zem_rp_title">Aston Martin premières film on DB10, its <i>Spectre</i> James Bond car</a></li><li data-position="6" data-poid="in-578" data-post-type="none"><a href="http://luciremen.com/20131121/jaguar-launches-f-type-coupe-at-los-angeles-auto-show/" class="zem_rp_thumbnail"><img src="http://luciremen.com/wp-content/uploads/1120i10-150x150.jpg" alt="Jaguar launches F-type coupé at Los Angeles Auto Show" width="150" height="150" /></a><a href="http://luciremen.com/20131121/jaguar-launches-f-type-coupe-at-los-angeles-auto-show/" class="zem_rp_title">Jaguar launches F-type coupé at Los Angeles Auto Show</a></li><li data-position="7" data-poid="in-268" data-post-type="none"><a href="http://luciremen.com/20120222/bentley-to-show-a-more-sporting-mulsanne-at-geneve-the-mulliner-driving-speci%ef%ac%81cation/" class="zem_rp_thumbnail"><img src="http://luciremen.com/wp-content/uploads/528304_Mulsanne_01-copy-150x150.jpg" alt="Bentley to show a more sporting Mulsanne at Genève: the Mulliner Driving Speciﬁcation" width="150" height="150" /></a><a href="http://luciremen.com/20120222/bentley-to-show-a-more-sporting-mulsanne-at-geneve-the-mulliner-driving-speci%ef%ac%81cation/" class="zem_rp_title">Bentley to show a more sporting Mulsanne at Genève: the Mulliner Driving Speciﬁcation</a></li></ul></div></div>
</div>
<div class="post-meta section-inner thin">
<div class="meta-block post-author">
<h2 class="meta-title">About the author</h2>
<div class="post-author-container group">
<img alt='' src='http://0.gravatar.com/avatar/3ff4a30ba116ea6ae1669c0b597d1b93?s=160&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/3ff4a30ba116ea6ae1669c0b597d1b93?s=320&#038;d=mm&#038;r=g 2x' class='avatar avatar-160 photo' height='160' width='160' loading='lazy' />
<div class="post-author-inner">
<h3><a href="http://luciremen.com/author/lucire-staff/" title="Posts by Lucire staff" rel="author">Lucire staff</a></h3>
<div class="author-links">
<a class="author-link-posts" href="http://luciremen.com/author/lucire-staff/">Author archive</a>
<a class="author-link-website" href="http://lucire.com">Author website</a>
</div>
</div>
</div>
</div>
<div class="meta-block post-cat-tags">
<h2 class="meta-title">About the post</h2>
<p class="post-categories"><a href="http://luciremen.com/category/gear/" rel="category tag">Gear</a></p>
<p class="post-tags"><a href="http://luciremen.com/tag/022/" rel="tag">022</a>, <a href="http://luciremen.com/tag/1970/" rel="tag">1970</a>, <a href="http://luciremen.com/tag/1970s/" rel="tag">1970s</a>, <a href="http://luciremen.com/tag/car/" rel="tag">car</a>, <a href="http://luciremen.com/tag/electric-car/" rel="tag">electric car</a>, <a href="http://luciremen.com/tag/electricity/" rel="tag">electricity</a>, <a href="http://luciremen.com/tag/england/" rel="tag">England</a>, <a href="http://luciremen.com/tag/environment/" rel="tag">environment</a>, <a href="http://luciremen.com/tag/land-rover/" rel="tag">Land Rover</a>, <a href="http://luciremen.com/tag/living/" rel="tag">living</a>, <a href="http://luciremen.com/tag/lucire/" rel="tag">Lucire</a>, <a href="http://luciremen.com/tag/luxury/" rel="tag">luxury</a>, <a href="http://luciremen.com/tag/luxury-line/" rel="tag">luxury line</a>, <a href="http://luciremen.com/tag/modernism/" rel="tag">modernism</a>, <a href="http://luciremen.com/tag/oxfordshire/" rel="tag">Oxfordshire</a>, <a href="http://luciremen.com/tag/range-rover/" rel="tag">Range Rover</a>, <a href="http://luciremen.com/tag/retro/" rel="tag">retro</a>, <a href="http://luciremen.com/tag/retromodernism/" rel="tag">retromodernism</a>, <a href="http://luciremen.com/tag/sustainability/" rel="tag">sustainability</a>, <a href="http://luciremen.com/tag/uk/" rel="tag">UK</a>, <a href="http://luciremen.com/tag/zero-emissions/" rel="tag">zero emissions</a></p>
<nav class="navigation post-nav" aria-label="Posts">
<h2 class="screen-reader-text">Post navigation</h2>
<div class="nav-links"><div class="nav-previous"><a href="http://luciremen.com/20221130/off-roading-lamborghini-style-in-a-huracan/" rel="prev">Off-roading Lamborghini style—in a Huracán</a></div></div>
</nav>
</div>
</div>
</article>
<div class="respond section bg-grey" name="respond">
<div class="section-inner thin">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/20221218/everrati-breathes-new-life-into-classic-range-rover-and-land-rover-vehicles-with-luxury-ev-conversions/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://luciremen.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='2006' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="cd80781787" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="186" /><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</div>
</div>
</main>
<footer class="footer section medium-padding bg-graphite" id="site-footer">
<div class="section-inner row group">
<div class="column column-1 one-third">
<div class="widgets">
<div class="widget_text widget widget_custom_html"><div class="widget_text widget-content"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="30" data-revive-id="0e871bac9eee6ce976e99823ca8b99f2"></ins>
<script async src="//adserver.jyanet.com/www/delivery/asyncjs.php"></script></div></div></div> </div>
</div>
<div class="column column-2 one-third">
<div class="widgets">
<div class="widget_text widget widget_custom_html"><div class="widget_text widget-content"><div class="textwidget custom-html-widget"><a href="http://lucire.tv"><img src="https://lucire.com/images/luciretv-54x46.png" height="46" width="54" vspace="3"></a>
<script src="https://geo.dailymotion.com/player/x7n6t.js" data-playlist="x7e7rc"></script>
</div></div></div> </div>
</div>
<div class="column column-3 one-third">
<div class="widgets">
<div class="widget_text widget widget_custom_html"><div class="widget_text widget-content"><div class="textwidget custom-html-widget"><a href="https://lucire.com"><img src="https://lucire.com/images/lucire-logo.svg" width="54" border=0 hspace=10></a> <strong>News headlines</strong></div></div></div><div class="widget widget_rss"><div class="widget-content"><h3 class="widget-title"><a class="rsswidget rss-widget-feed" href="https://lucire.com/insider/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://luciremen.com/wp-includes/images/rss.png" alt="RSS" loading="lazy" /></a> <a class="rsswidget rss-widget-title" href="https://lucire.com/insider">Lucire</a></h3><ul><li><a class='rsswidget' href='https://lucire.com/insider/20221220/couture-comix-no-32/'>Couture Comix, no. 32</a></li><li><a class='rsswidget' href='https://lucire.com/insider/20221218/the-metaverse-goes-mainstream/'>The metaverse goes mainstream</a></li><li><a class='rsswidget' href='https://lucire.com/insider/20221218/everrati-breathes-new-life-into-classic-range-rover-and-land-rover-vehicles-with-luxury-ev-conversions/'>Everrati breathes new life into classic Range Rover and Land Rover vehicles with luxury EV conversions</a></li><li><a class='rsswidget' href='https://lucire.com/insider/20221214/riyadh-modest-fashion-show-in-for-a-treat-stitch-fix-forecasts-2023-kathy-ireland-honoured/'>Riyadh Modest Fashion Show: in for a treat; Stitch Fix forecasts 2023; Kathy Ireland honoured</a></li><li><a class='rsswidget' href='https://lucire.com/insider/20221213/couture-comix-no-31/'>Couture Comix, no. 31</a></li></ul></div></div> </div>
</div>
</div>
</footer>
<div class="credits section light-padding">
<div class="credits-inner section-inner group">
<p class="fleft">
<span class=copyright>Copyright &copy;2011&ndash;22 by <a href="http://jyanet.com/media">JY&amp;A
Media</a>, a division of <a href="http://jyanet.com">Jack Yan &amp; Associates</a>.
All rights reserved. <br /><a href="http://jyanet.com/legal.htm">JY&amp;A terms and conditions and privacy policy apply to viewing this site.</a> All prices in US dollars except where indicated. Contact us <a href="http://lucire.com/feedback.html">here</a>.</span>
</p>
<p class="fright">
<span>Theme by <a href="https://andersnoren.se">Anders Nor&eacute;n</a> &mdash; </span><a href="#" class="tothetop">Up &uarr;</a>
</p>
</div>
</div>
<script type='text/javascript' src='http://luciremen.com/wp-content/themes/radcliffe/assets/js/global.js?ver=6.0.1' id='radcliffe_global-js'></script>
<script type='text/javascript' src='http://luciremen.com/wp-includes/js/comment-reply.min.js?ver=6.0.1' id='comment-reply-js'></script>
</body>
</html>